obligada > linux.debian.user.spanish

Miguel Matos (22-10-2018, 16:30)
Muy buenas, acá vuelvo a plantear una duda muy exótica que me surgió: me
han indicado que en una máquina que usa la más reciente versión de debian,
la 8 para más señas (pero no tengo más pistas del hardware que tiene), le
quieren instalar el xampp para agregar un software ERP, pero el caso es que
éste trabaja con postgresql y no con mysql/mariadb. He indagado más o
menos, y lo que mejor se consigue es para windows 7/8/10. Me preguntaba si
alguno acá se ha instalado el xampp que le haya puesto postgresql para
darme más pistas...
Gonzalo Rivero (22-10-2018, 17:10)
El lun, 22-10-2018 a las 10:26 -0400, Miguel Matos escribió:
> Muy buenas, acá vuelvo a plantear una duda muy exótica que me surgió:
> me han indicado que en una máquina que usa la más reciente versión de
> debian, la 8 para más señas (pero no tengo más pistas del hardware
> que tiene), le quieren instalar el xampp para agregar un software
> ERP, pero el caso es que éste trabaja con postgresql y no con
> mysql/mariadb. He indagado más o menos, y lo que mejor se consigue es
> para windows 7/8/10. Me preguntaba si alguno acá se ha instalado el
> xampp que le haya puesto postgresql para darme más pistas...


apt-get install postgresql-10 php-pgsql
Matias Mucciolo (22-10-2018, 17:10)
On Monday, October 22, 2018 10:26:14 AM -03 Miguel Matos wrote:
> Muy buenas, acá vuelvo a plantear una duda muy exótica que me surgió: me
> han indicado que en una máquina que usa la más reciente versión de debian,
> la 8 para más señas (pero no tengo más pistas del hardware que tiene), le
> quieren instalar el xampp para agregar un software ERP, pero el caso es que
> éste trabaja con postgresql y no con mysql/mariadb. He indagado más o
> menos, y lo que mejor se consigue es para windows 7/8/10. Me preguntaba si
> alguno acá se ha instalado el xampp que le haya puesto postgresql para
> darme más pistas...
> --
> Ayuda para hacer preguntas inteligentes:


buenas
no se te entiende mucho pero empecemos que el ultimo debian
stable es el 9 stretch y si preguntas si existe postgresql
para debian la respuesta es si..

postgresql-9.6

en debian 9

saludos
Miguel Matos (22-10-2018, 23:20)
On Mon, Oct 22, 2018 at 11:04 AM Gonzalo Rivero <fishfromsalta>
wrote:

> El lun, 22-10-2018 a las 10:26 -0400, Miguel Matos escribió:
> apt-get install postgresql-10 php-pgsql

Ya me imaginaba que habrían respuestas así, así que diré "ya existe
postgresql previamente instalado", pero ya obtuve una nueva perspectiva del
problema: resulta es que el ERP que usa la empresa tiene un vulgo búlgaro
problema, que cuando intenta hacer una transacción SQL, la trunca en cierto
punto, y la tabla resultante sale "cortada" desde el punto donde se corta
la transacción SQL... por lo que les propusieron instalar el ERP a través
de XAMPP, pero como ya muchos habrán visto, XAMPP viene es con mysql
instalado, y el ERP usa postgres... por lo que resolver esto es un paso más
que vital. Y sí, ya sé que el problema va más a la parte de la programación
en PHP y Postgresql, pero igual necesitaba algo de asesoría ya que todo se
está montando sobre debian.

PD.: Por ahora tiene que ser Debian 7, no 8 ni 9 (mala mía), por
particularidades de este ERP, que funciona sólamente con estos SO's
Felix Perez (23-10-2018, 00:30)
El lun., 22 de oct. de 2018 a la(s) 18:13, Miguel Matos
(matospmiguela) escribió:
> On Mon, Oct 22, 2018 at 11:04 AM Gonzalo Rivero <fishfromsalta>wrote:
> Ya me imaginaba que habrían respuestas así, así que diré "ya existe postgresql previamente instalado", pero ya obtuve una nueva perspectiva del problema: resulta es que el ERP que usa la empresa tiene unvulgo búlgaro problema, que cuando intenta hacer una transacciónSQL, la trunca en cierto punto, y la tabla resultante sale "cortada" desdeel punto donde se corta la transacción SQL... por lo que les propusieron instalar el ERP a través de XAMPP, pero como ya muchos habránvisto, XAMPP viene es con mysql instalado, y el ERP usa postgres... por loque resolver esto es un paso más que vital. Y sí, ya sé queel problema va más a la parte de la programación en PHP y Postgresql, pero igual necesitaba algo de asesoría ya que todo se está montando sobre debian.


Estimado Miguel, sin mala intención y con todo respeto, pero podría
volver a plantear cual es el problema y el escenario. Redactar bien
solo amerita un poquito de esfuerzo.

Por lo poco que alcanzo a entender, el instalar a través de XAMPP,
¿Instalar qué? ¿El ERP?, según tú ¿Eso te solucionaría un problema de
una transacción Postgresql?. O no responde la aplicación o no responde
Postgresql incluso habría que descartar conectividad, aunque si se
pierde la "red" el commit de la transacción, por lo que se, no
quedaría truncado sino que no se realizaría.

XAMPP, te permite instalar Apache, PHP, MariaDB/Mysql. Si lo quieres
usar, instala solo Apache y PHP no instales MariaDb/Mysql y luego
configuras ambos para que se conecten/usen Postgresql.

Saludos.
Miguel Matos (23-10-2018, 15:20)
On Mon, Oct 22, 2018 at 6:27 PM Felix Perez <felix.listadebian>
wrote:

[..]
> Estimado Miguel, sin mala intención y con todo respeto, pero podría
> volver a plantear cual es el problema y el escenario. Redactar bien
> solo amerita un poquito de esfuerzo.


Hago lo mejor posible porque a mí tambíen me hace jalarme los pelos cuando
no me dicen exactamente lo que necesitan, por lo que tengo que insistir
cuatro o más veces que planteen el problema

[..]
> normas de la lista:
> como hacer preguntas inteligentes:
>

El asunto es este: el ERP se llama SIGESP[1], que en este caso es un
software basado en web para la adminstración pública, y usa PostgreSQL para
guardar los datos. Se me olvidó indicarlo, pero ya tanto el apache como el
php y postgres están instalados independiente. Hay un detalle particular
que es cuando se ejecuta cierta transacción de "update", ésta no llega
completa y trunca los datos recibidos, y la tabla que muestra se corta (no
he podido tomar screenshots en donde estoy ejecutando eso porque es remoto
con teamviewer). Les propusieron colocar el sigesp en el xampp, porque
hicieron lo mismo desde wampserver con windows instalado y sí funcionó, y
necesitan que el ERP se ejecute sobre debian, y ya he probado todo lo que
sé y no se me ocurre nada.

Y por si se lo preguntan, alguien me sugirió probar revisar los logs, y en
el de postgresql sale esta línea:
2018-10-20 12:35:03 VET SENTENCIA: UPDATE spg_cuentas SET
distribuir='0', enero=0.00, febrero=0.00,
marzo=0.00, abril=0.00, mayo=0.00,
junio=0.00, julio=0.00, agosto=0.00,
septiembre=, octubre=, noviembre=, diciembre=
WHERE codemp='0001' AND codestpro1='00000000000000000000AC-02'
AND codestpro2='0000000000000000000000001' AND
codestpro3='0000000000000000000000005' AND
codestpro4='0000000000000000000000000' AND
codestpro5='0000000000000000000000000' AND estcla='A' AND
spg_cuenta = '403100100'

Y en el apache sale algo tipo undefined index (variable) at (localizacion
de archivo) linea (tal), como 400 veces... y desde el lugar donde se
encuentra el '403100100' se truncan los datos y sale horrible...

Es seguro que el problema es más de php que de debian, pero si puedo
alivianarlo en el debian instalado sería más que satisfactorio para mí
porque no tendría que preocuparme por instalar el postgresql sobre xampp.
Felix Perez (23-10-2018, 16:50)
El mar., 23 de oct. de 2018 a la(s) 10:17, Miguel Matos
(matospmiguela) escribió:
> On Mon, Oct 22, 2018 at 6:27 PM Felix Perez <felix.listadebian>wrote:
> Hago lo mejor posible porque a mí tambíen me hace jalarme los pelos cuando no me dicen exactamente lo que necesitan, por lo que tengo que insistir cuatro o más veces que planteen el problema
> El asunto es este: el ERP se llama SIGESP[1], que en este caso es un software basado en web para la adminstración pública, y usa PostgreSQL para guardar los datos. Se me olvidó indicarlo, pero ya tanto el apache como el php y postgres están instalados independiente. Hay un detalle particular que es cuando se ejecuta cierta transacción de "update", ésta no llega completa y trunca los datos recibidos, y la tabla que muestra se corta (no he podido tomar screenshots en donde estoy ejecutando eso porque es remoto con teamviewer). Les propusieron colocar el sigesp en el xampp, porque hicieron lo mismo desde wampserver con windows instalado ysí funcionó, y necesitan que el ERP se ejecute sobre debian, y ya he probado todo lo que sé y no se me ocurre nada.
> Y por si se lo preguntan, alguien me sugirió probar revisar los logs, y en el de postgresql sale esta línea:
> 2018-10-20 12:35:03 VET SENTENCIA: UPDATE spg_cuentas SET distribuir='0', enero=0.00, febrero=0.00, marzo=0.00, abril=0.00, mayo=0.00, junio=0.00, julio=0.00, agosto=0.00, septiembre=, octubre=, noviembre=, diciembre= WHERE codemp='0001' AND codestpro1='00000000000000000000AC-02' AND codestpro2='0000000000000000000000001' AND codestpro3='0000000000000000000000005' AND codestpro4='0000000000000000000000000' AND codestpro5='0000000000000000000000000' AND estcla='A' AND spg_cuenta = '403100100'
> Y en el apache sale algo tipo undefined index (variable) at (localizacionde archivo) linea (tal), como 400 veces... y desde el lugar donde se encuentra el '403100100' se truncan los datos y sale horrible...
> Es seguro que el problema es más de php que de debian, pero si puedoalivianarlo en el debian instalado sería más que satisfactorio para mí porque no tendría que preocuparme por instalar el postgresql sobre xampp.
> --


Revisa los log de php o activa la "verbosidad de los errores" para
depurar el codigo, por ahí te debería dar un poco más de datos de
información.

Otra cosa es que no haz indicado versiones de sistema y paquetes.
Pega la línea de error de apache completa.

Si un problema similar lo solucionaron instalando otro xamp, puede ser
algún problemas de versiones o librerías revisa y compara ambas
instalaciones.

Saludos.
Paynalton (23-10-2018, 17:20)
en PHP es común tener lo de undefined index.

Pregunta: La ejecución se interrumpe después de un tiempo o es
instantáneo????

Por defecto PHP tiene 30 segundos para ejecutar un script antes de
considerar el proceso como colgado y matar la ejecución.

Como te dicen, activa los mensajes de depuración y revisa el log de apache
para ver que sucede en el preciso instante en que se detiene tu proceso y
encontrar la razón.

El mar., 23 de oct. de 2018 a la(s) 09:48, Felix Perez <
felix.listadebian> escribió:
[..]
Antonio Galicia (23-10-2018, 18:10)
Hola Miguel, buen día.

Es raro que necesites una versión específica de debian lo cual sólo puede
ser porque se requiere de una versión particular de alguno de los
componentes. Dices que hay una instalación funcionando, ¿puedes ver la
versión de apache, php, los módulos y postgresql en la instalación que sí
funciona?

Ahora, cómo resolverlo, eso dependerá de la razón por la queno funciona y
es lo que debemos determinar

Saludos,
Antonio Galicia

Eram quod es, eris quod sum
Miguel Matos (24-10-2018, 15:30)
On Tue, Oct 23, 2018 at 10:48 AM Felix Perez <felix.listadebian>
wrote:

[..]
> información.
> Otra cosa es que no haz indicado versiones de sistema y paquetes.
> Pega la línea de error de apache completa.


Como la cosa se realiza en remoto no he tenido la oportunidad de copiar los
logs para analizarlo, pero en lo que tenga acceso nuevamente los tomaré
"prestado", con calidad de borrado posterior. Del apache no tengo muchas
pistas, pero del php sí: es el 5.1, y de postgresql también: es el 8.4, y
reciente ayudé a pasarlo al 9.1 porque era el que trae wheezy, luego de
haber insisitido y finalmente convencer de subir de squeeze a wheezy

Ya había habilitado la verbosidad de los errores en php para saber más o
menos qué pasaba, y por ahí supe que me pasaba lo del undefined index.
Lástima que no lo copié a tiempo.
[..]
Miguel Matos (24-10-2018, 16:00)
On Tue, Oct 23, 2018 at 11:10 AM Paynalton <cxescalona> wrote:

> en PHP es común tener lo de undefined index.
> Pregunta: La ejecución se interrumpe después de un tiempo o es
> instantáneo????


Pasa casi que medio minuto e indica que ha pasado un error, y luego sucede
lo que comenté antes.

> Por defecto PHP tiene 30 segundos para ejecutar un script antes de
> considerar el proceso como colgado y matar la ejecución.


Posiblemente sea eso, pero no sé exáctamente cómo subirlo. ¿Es en
max_execution_time y/o en max_input_time? Pues ambos dos los puse en 600 e
igual siguen con el error...

> Como te dicen, activa los mensajes de depuración y revisa el log de apache
> para ver que sucede en el preciso instante en que se detiene tu proceso y
> encontrar la razón.


Cuando tenga acceso a los logs se los compartiré...
[..]
Paynalton (25-10-2018, 01:30)
Mirate esto:



y esto:



El mié., 24 de oct. de 2018 a la(s) 08:50, Miguel Matos <
matospmiguela> escribió:
[..]
Miguel Matos (05-11-2018, 15:10)
---------- Forwarded message ---------
From: Miguel Matos <matospmiguela>
Date: Wed, Oct 24, 2018 at 9:49 AM
Subject: Re: Acoplar postgresql con xampp en debian de 64 bits
To: debian-user-spanish <
debian-user-spanish>

On Tue, Oct 23, 2018 at 11:10 AM Paynalton <cxescalona> wrote:

> en PHP es común tener lo de undefined index.
> Pregunta: La ejecución se interrumpe después de un tiempo o es
> instantáneo????


Pasa casi que medio minuto e indica que ha pasado un error, y luego sucede
lo que comenté antes.

> Por defecto PHP tiene 30 segundos para ejecutar un script antes de
> considerar el proceso como colgado y matar la ejecución.


Posiblemente sea eso, pero no sé exáctamente cómo subirlo. ¿Es en
max_execution_time y/o en max_input_time? Pues ambos dos los puse en 600 e
igual siguen con el error...

> Como te dicen, activa los mensajes de depuración y revisa el log de apache
> para ver que sucede en el preciso instante en que se detiene tu proceso y
> encontrar la razón.


Cuando tenga acceso a los logs se los compartiré...

> El mar., 23 de oct. de 2018 a la(s) 09:48, Felix Perez <
> felix.listadebian> escribió:


Después de dar varias vueltas al asunto, y de probar con las
configuraciones que nos insistieron, leímos una cuestión sobre algo llamado
suhosin, y vimos que en el servidor principal estaba presente, pero tenía
ciertas líneas descomentadas, por lo que procedimos a habilitarlas y
colocarles la configuración recomendada, y cruzando los dedos probamossi
el problema se resolvería, y donde salía la falla hicimos la prueba, ¡y
salió victoriosa!

Luego probamos con datos reales, y también logró funcionar. Por lo que ya
puedo dar el problema como solucionado, y darles las gracias por el paoyo
prestado.
Temas Similares