obligada > microsoft.* > microsoft.servicios.web

Francisco Chávez (28-06-2012, 16:03)
Estimados junto con saludarles, les hago la siguiente consulta

Estoy consumiendo un webservice y me está arrojando el siguiente Error:

"Service call not completed, in the Service Proxy: static endpoint pattern"

El caso es que lo estoy consumiendo de la siguiente forma

wsCLIENTEResponse.EReturn = wsCliente.YRecibEvents(wsRequest);

y mi AppConfig es el siguiente

<system.serviceModel>
<bindings>
<customBinding>
<binding name="YWS_RECIB_EVENTS">
<!-- WsdlImporter encontró aserciones de directiva no reconocidas en ServiceDescription 'urn:sap-com:document:sap:soap:functions:mc-style': -->
<!-- <wsdl:binding name='ZWS_RECIB_EVENT'> -->
<!-- <wsaw:UsingAddressing xmlns:wsaw="http://schemas.xmlsoap.org/ws/2004/08/addressing">..</wsaw:UsingAddressing> -->
<!-- <saptrnbnd:OptimizedXMLTransfer xmlns:saptrnbnd="http://www.sap.com/webas/710/soap/features/transportbinding/">..</saptrnbnd:OptimizedXMLTransfer> -->
<!-- <sapattahnd:Enabled xmlns:sapattahnd="http://www.sap.com/710/features/attachment/">..</sapattahnd:Enabled> -->
<textMessageEncoding maxReadPoolSize="64" maxWritePoolSize="16"
messageVersion="Soap11" writeEncoding="utf-8">
<readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
maxBytesPerRead="4096" maxNameTableCharCount="16384" />
</textMessageEncoding>
<httpTransport manualAddressing="false" maxBufferPoolSize="524288"
maxReceivedMessageSize="65536" allowCookies="false" authenticationScheme="Anonymous"
bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard"
keepAliveEnabled="true" maxBufferSize="65536" proxyAuthenticationScheme="Anonymous"
realm="" transferMode="Buffered" unsafeConnectionNtlmAuthentication="false"
useDefaultWebProxy="false" proxyAddress="http://000.00.000.000:0000" />
</binding>
</customBinding>
</bindings>
<client>
<endpoint address="http://000.00.000.000:0000/events" binding="customBinding"
bindingConfiguration="YWS_RECIB_EVENTS" contract="ws.CLIENTE.yws_recib_events"
name="YWS_RECIB_EVENTS" />
</client>
</system.serviceModel>

Alguien me puede orientar con el error que está apareciendo, si es de mi lado o bien algo de la configuración del ambiente en donde está alojadoel WebService?

Agradezco la ayuda.
Francisco Chávez (28-06-2012, 18:51)
Gracias de todas formas , "lo solucioné", en realidad era un tema de donde yo consumia el webservice.

Gracias!!!!
Temas Similares