obligada > linux.debian.user.spanish

juan carlos (23-01-2019, 01:50)
buenas como les va?, he querido instalar debian 9.6 e instalar ciertos
servidores, como apache, mysql, openssh y inspircd, el caso esque recibo
errores extraños, por ejemplo con el mysql todo se descarga bien y al
momento de instalar, me dice que error al procesar el paquete, que habia
dependencias incumplidas, diciendo que mysql-server dependia de
mysql-server-5.7 pero que ese paquete no está, pero si hago apt download
mysql-server se me baja perfectamente, por si las moscas probe con
ubuntu  y ocurre exactamente igual, curiosamente solo ocurre con los
paquetes de servidores, ya que con paquetes normales se instalan
correctamente, no he encontrado nada en google que me oriente sobre este
error, no he colocado la salida porque no se si se debe plasmar entera
aqui o atraves de un link a un archivo de texto, en cualquier caso si la
necesitan puedo ponerla aqui entera sin cortes
Galvatorix Torixgalva (23-01-2019, 10:30)
Hola,

voy a intentar responder correctamente porque el mensaje es (al menos para
mi) un poco confuso.

Si instalas varios servidores tienes que tener en cuenta que podria haber
problemas de algun tipo, ya sea en el propio sistema o entre los propios
servidores.

Si un paquete no esta disponible mira en Internet el motivo. Una posible
razon es que existan problemas de seguridad y que lo hayan retirado
mientras lo solucionan.

No se bien que te has bajado con apt-download, si es el codigo fuente o el
que.

Para envios largos de texto podrias usar pastebin, una parte para cualquier
cosa que parezca que algo no va bien y otra para todo lo demas.

Un saludo
juan carlos (23-01-2019, 21:00)
El 23/01/19 a las 08:27, Galvatorix Torixgalva escribió:
[..]
> Para envios largos de texto podrias usar pastebin, una parte para
> cualquier cosa que parezca que algo no va bien y otra para todo lo demas.
> Un saludo

hola galvatorix, no creo que se trate de conflictos por tener varios
servicios en un mismo servidor, he investigado y parece ser que oracle
proporciona su propio repo para mysql 6.7 y 8.0, pero ese no es motivo
para no subir al repo de debian/ubuntu las nuevas versiones ya que hay
varias ediciones, entre ellas community que es la open source, aqui
pongo el link al paste (que por cierto no conocia ese servicio)
he usado una live de ubuntu para no tener
que instalar otra vez, pero ese mismo error me da en debian 9.6, y si me
cuentas que podria ser por usar live ya te digo yo que no, porque
instalo samba, instalo bind y perfecto
Felix Perez (24-01-2019, 03:50)
El mié., 23 de ene. de 2019 a la(s) 15:52, juan carlos
(nerus492) escribió:
[..]
> que instalar otra vez, pero ese mismo error me da en debian 9.6, y si me
> cuentas que podria ser por usar live ya te digo yo que no, porque
> instalo samba, instalo bind y perfecto


Hola, podrías reseñar y explicar de manera más clara qué has echo y en
qué, hablas de debian y publicas errores de ubuntu.

- entorno?
-versión debian?
- modo de instalación?
- repositorios en tu sources.list?
- probaste con MariaDB?
- tipo hardware?
- virtualización?
- Etc.?

Suerte.
juan carlos (24-01-2019, 05:10)
El 24/01/19 a las 01:41, Felix Perez escribió:
[..]
> - virtualización?
> - Etc.?
> Suerte.

hola, como ya dije el error me da en debian 9.6 (ultima) y por las
moscas (por si a caso) tambien lo probe en ubuntu, el error me da en
ambos sistemas, la version de ubuntu probada es la 18.04.1 ya que en
debian 8 y ubuntu 16 si funciona, por lo que debo entender que es un
error en el paquete, si probe con mariadb 10 y con la extension mysql de
php, ya que no hay extension de mariadb para php, almenos no en el repo,
los repos de debian son los oficiales, el main, el contrib y el
non-free, los mensajes de error estan en el paste que nvie ya, el
hardware no tiene nada que ver para los problemas de descarga de
paquetes, ya que se trata de un error en ese paquete en concreto porque
en debian 8 y ubuntu 16 si descarga e instala perfecto,
Galvatorix Torixgalva (24-01-2019, 10:00)
Hola,

creo, y digo creo, que es un problema de disponibilidad. En el pastebin que
has puesto veo avisos de problemas de la linea 70 para abajo.

Algo ha sucedido con las dependencias y de momento no estan disponibles.
Creo que tendras que esperar a que los vuelvan a poner.

Que no esten disponibles en una distribucion y si que lo esten en otra es
algo que puede suceder, al fin y al cabo son repositorios diferentes.

Un saludo
kazabe (24-01-2019, 15:30)
Hola.

Tambien pienso que pude ser un problema de disponibilidad. Pero de
todos modos te recomendaria que no insistas con mysql y pruebes con
MariaDB.

saludos.

«Existen dos cosas infinitas:
el universo y la estupidez humana... y no estoy muy seguro de la primera» :
Albert Einstein

On Thu, 24 Jan 2019 at 02:52, Galvatorix Torixgalva
<galvatorix2017> wrote:
[..]
Felix Perez (24-01-2019, 23:20)
El jue., 24 de ene. de 2019 a la(s) 00:01, juan carlos
(nerus492) escribió:
[..]
> hardware no tiene nada que ver para los problemas de descarga de
> paquetes, ya que se trata de un error en ese paquete en concreto porque
> en debian 8 y ubuntu 16 si descarga e instala perfecto,


Se me ocurre limpiar la cache de paquetes y probar la instalación con
apt o probar instalar mediante aptitude.
Saludos.
juan carlos (30-01-2019, 23:00)
El 24/01/19 a las 07:52, Galvatorix Torixgalva escribió:
> Hola,
> creo, y digo creo, que es un problema de disponibilidad. En el
> pastebin que has puesto veo avisos de problemas de la linea 70 para abajo.
> Algo ha sucedido con las dependencias y de momento no estan
> disponibles. Creo que tendras que esperar a que los vuelvan a poner.
> Que no esten disponibles en una distribucion y si que lo esten en otra
> es algo que puede suceder, al fin y al cabo son repositorios diferentes.
> Un saludo

pero si fuese eso porque falla en todas las distros basadas en debian?
es decir si fuese un fallo de dependencias porque al instalar mariadb si
se instalan las librerias de mysql? pero lo curioso esque no lo hacen si
se instala mysql, lo mlo de mariadb esque no configura el usuario
principal automaticamente pero por lo demas es compatible al 99% con
mysql salvo por la forma de almacenar los datos y que es unos segundos
mas lento
Felix Perez (31-01-2019, 04:50)
El mié., 30 de ene. de 2019 a la(s) 17:57, juan carlos
(nerus492) escribió:
> El 24/01/19 a las 07:52, Galvatorix Torixgalva escribió:
> pero si fuese eso porque falla en todas las distros basadas en debian?
> es decir si fuese un fallo de dependencias porque al instalar mariadb si
> se instalan las librerias de mysql? pero lo curioso esque no lo hacen si
> se instala mysql, lo mlo de mariadb esque no configura el usuario
> principal automaticamente pero por lo demas es compatible al 99% con
> mysql salvo por la forma de almacenar los datos y que es unos segundos
> mas lento No se por qué tengo la idea que no nos has dicho todo, pero en fin:




Saludos.
Calabaza (31-01-2019, 20:30)
El mar., 22 ene. 2019 a las 20:44, juan carlos (<nerus492>) escribió:

> buenas como les va?,


Bastante estresado al leer este hilo, pero antes de contestar quisiera sugerir
a todos los que están participando en este hilo y en especial a tí Juan Carlos,
lean estos links:





La sugerencia se debe a que he querido contestar a este hilo
contemplando todas las respuestas de los demás participantes,
pero debido a mi limitado tiempo y a que no siguen las normas de la lista,
tendré que contestar a este primer email y si me repito con las
contribuciones de los demás, disculpas de antemano.

> he querido instalar debian 9.6 e instalar ciertos servidores,
> como apache, mysql, openssh y inspircd,
> el caso esque recibo errores extraños,


¿cuáles errores?

> por ejemplo con el mysql todo se descarga bien
> y al momento de instalar,
> me dice que error al procesar el paquete,
> que habia dependencias incumplidas,
> diciendo que mysql-server dependia de mysql-server-5.7
> pero que ese paquete no está,
> pero si hago apt download mysql-server se me baja perfectamente,
> por si las moscas probe con ubuntu y ocurre exactamente igual,


Antes que nada una aclaración, Debian no es Ubuntu, por tanto,
puede que el nombre y hasta el funcionamiento de los paquetes
coincida; pero es un error pensar que
"si funciona en uno será igual en el otro".

El error que aparece en el link que indicaste (),
efectivamente es de Ubuntu y por tanto no nos sirve para solucionar
un problema específico en Debian.

No obstante te puedo indicar lo siguiente:
a) En Debian 9 mariadb reemplaza a mysql, por tanto, en Debian 9,
no hay un paquete mysql-server-5.7, puedes leerte los siguientes links:



Aquí se pueden ver las dependencias de los paquetes:




b) El error menciona que: no puede configurar el paquete; esto
significa que sí descargó el paquete,
pero que dio un error al configurarlo y en el log se puede ver que es
un error del systemd
al intentar activar el servicio:

-------------------------------------------------------- INICIO
----------------------------------------------------------
Job for mysql.service failed because
the control process exited with error code.
See "systemctl status mysql.service"
and "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
? mysql.service - MySQL Community Server
Loaded: loaded (/lib/systemd/system/mysql.service;
enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code)
since Wed 2019-01-23 18:31:13 UTC; 9ms ago
Process: 4577 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre
(code=exited, status=1/FAILURE)

ene 23 18:31:13 ubuntu systemd[1]: mysql.service:
Control process exited, code=exited status=1
ene 23 18:31:13 ubuntu systemd[1]: mysql.service:
Failed with result 'exit-code'.
ene 23 18:31:13 ubuntu systemd[1]:
Failed to start MySQL Community Server.

dpkg: error al procesar el paquete mysql-server-5.7 (--configure):
instalado mysql-server-5.7 paquete
post-installation guión el subproceso devolvió
un error con estado de salida 1

dpkg: problemas de dependencias impiden
la configuración de mysql-server:
mysql-server depende de mysql-server-5.7;
sin embargo:
El paquete `mysql-server-5.7'
no está configurado todavía.

dpkg: error al procesar el paquete
mysql-server (--configure):
problemas de dependencias - se deja sin configurar
------------------------------------------------------------ FIN
----------------------------------------------------------

> pero si hago apt download mysql-server se me baja perfectamente,


Con respecto a eso puedo indicar que es necesario
ver el contenido de tu archivo /etc/apt/sources.list y
de los ficheros dentro de la carpeta /etc/apt/sources.list.d/
para entender desde qué repositorio está bajando el paquete.

Porque como mencioné previamente mysql-server-5.7 no está en Stretch;
sólo está en el repositorio Sid (unstable).

> curiosamente solo ocurre con los paquetes de servidores,
> ya que con paquetes normales se instalan correctamente,


¿cuáles son los paquetes "normales"?

Hasta aquí sólo he visto un error, en Ubuntu, de configuración de mysql,
no hay nada de otros errores al instalar los demás servicios en Debian..

> no he encontrado nada en google que me oriente sobre este error,
> no he colocado la salida porque no se si se debe plasmar entera
> aqui o atraves de un link a un archivo de texto,
> en cualquier caso si la necesitan puedo ponerla aqui entera sin cortes


> hola galvatorix, no creo que se trate de conflictos por tener varios
> servicios en un mismo servidor,


No he visto ningún error, con respecto a esto.

> he investigado y parece ser que oracle proporciona
> su propio repo para mysql 6.7 y 8.0,
> pero ese no es motivo para no subir al repo de debian/ubuntu
> las nuevas versiones ya que hay varias ediciones,
> entre ellas community que es la open source,


Esto no es tanto así como supones, hay licencias de uso y justamente
porque ha cambiado la licencia de uso (y de distribución de parches de
seguridad)
es que en Debian 9 se ha optado por mariadb.

> he usado una live de ubuntu para no tener que instalar otra vez,
> pero ese mismo error me da en debian 9.6, y si me
> cuentas que podria ser por usar live ya te digo yo que no, porque
> instalo samba, instalo bind y perfecto


Lo ideal sería que muestres el log de la instalación real,
o en su defecto de la reproducción con un live cd de Debian.

[..]
> el hardware no tiene nada que ver para los problemas de descarga de
> paquetes, ya que se trata de un error en ese paquete en concreto
> porque en debian 8 y ubuntu 16 si descarga e instala perfecto,


Que funcione en Debian 8, y otro SO no tiene nada que ver, es un caso
específico: en Debian 9 y el mensaje de error debe ser en Debian 9 para poder
ver exactamente qué sucede.

> pero si fuese eso porque falla en todas las distros basadas en debian?


¿y porqué deberíamos saber eso (esta es una lista de Debian)?

No obstante, si siguen las políticas de Debian,
hay muchas probabilidades que se comporten igual ;-)

> es decir si fuese un fallo de dependencias
> porque al instalar mariadb si se instalan las librerias de mysql?


Como mencioné más arriba, no es un fallo de dependencias.

> pero lo curioso es que no lo hacen si se instala mysql,
> lo mlo de mariadb esque no configura el usuario
> principal automaticamente


Puedes reportar un bug pidiendo ese comportamiento.

Atentamente,
juan carlos (31-01-2019, 20:40)
El 31/01/19 a las 08:30, Galvatorix Torixgalva escribió:
[..]
> entienda lo que quiero decir a poner acentos, y eso es simplemente
> porque ciertos temas del lenguaje nunca se me han dado bien.
> Un saludo

al igual que tu prefiero omitir algunos caracteres para escribir mas
rapido, ya que con o sin ellos se entiende perfectamente, la informacion
que os expuse esta perfectamente clara y confisa, en el paste que envie
esta indicado los errores y la forma que sigo para instalarlo, no se que
mas info necesitais, ya que como dije no hay mas factores a tener en
cuenta, sigo creyendo que es un error de los paquetes, mariadb tarda 10
segundos mas que mysql en bajarse, (probado en diferentes instalaciones,
cada instalacion en una maquina distinta), ademas mariadb debe tener un
error porque segun el tutorial de configuracion que esta en
para
cambiar el password del root debo ejecutar mysql_secure_installation y
efectivamente se ejecuta, el tutorial dice que el pass del rot esta en
blanco, por lo que pulso enter y deberia aceptarlo, pero en su lugar me
dice error acceso denegado para usuario root, probe a poner tambien un
espacio en blanco a ver si por un casual los mantenedores hicieron
cambios a esto, pero no, igualmente me da acceso denegado, por todo esto
creo que no es mi culpaa sino de una mala gestion de paquetes
Temas Similares