obligada > linux.debian.user.spanish

quintocorreo (06-11-2018, 02:00)
Hola tras intentar instalar OpenProject sigo sin alcanzar éxito para
utilizarlo es un aporte para una ONG el que se desea realizar y al final
obtengo este resultado.

root@Coordinacion:/home/coordinacion# openproject configure

Launching installer for openproject...

Selected addons: legacy-installer mysql apache2 repositories smtp memcached
openproject

[legacy-installer] ./bin/configure

[mysql] ./bin/configure

DONE

[apache2] ./bin/configure

DONE

[repositories] ./bin/configure

DONE

[smtp] ./bin/configure

DONE

[memcached] ./bin/configure

DONE

[openproject] ./bin/configure

[legacy-installer] ./bin/preinstall

[mysql] ./bin/preinstall

[apache2] ./bin/preinstall

[repositories] ./bin/preinstall

Module perl already enabled

Module dav already enabled

Considering dependency dav for dav_svn:

Module dav already enabled

Module dav_svn already enabled

[Mon Nov 05 13:14:18.661139 2018] [so:warn] [pid 3411] AH01574: module
dav_module is already loaded, skipping

AH00558: apache2: Could not reliably determine the server's fully qualified
domain name, using 127.0.1.1. Set the 'ServerName' directive globally to
suppress this message

Your MPM seems to be threaded. Selecting cgid instead of cgi.

Module cgid already enabled

[smtp] ./bin/preinstall

[memcached] ./bin/preinstall

[openproject] ./bin/preinstall

[legacy-installer] ./bin/postinstall

[mysql] ./bin/postinstall

Generating /etc/openproject/conf.d/database...

[apache2] ./bin/postinstall

Module rewrite already enabled

Module proxy already enabled

Considering dependency proxy for proxy_http:

Module proxy already enabled

Module proxy_http already enabled

Module headers already enabled

Module expires already enabled

Considering dependency filter for deflate:

Module filter already enabled

Module deflate already enabled

Module filter already enabled

Site openproject already enabled

[repositories] ./bin/postinstall

No repositories have been configured. Skipping configuration.

[smtp] ./bin/postinstall

[memcached] ./bin/postinstall

[openproject] ./bin/postinstall

rake aborted!

URI::InvalidURIError: bad URI(is not URI?):
postgresql://[user[:password]@][host][:port][/dbname][?param1=value1&...]

openproject config:set
DATABASE_URL=postgresql://[user[:password]@][host][:port][/dbname][?param1=value1

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:38:in
`initialize'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:268:in
`new'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:268:in
`resolve_url_connection'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:256:in
`resolve_hash_connection'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:231:in
`resolve_connection'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:141:in
`resolve'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:161:in
`block in resolve_all'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:160:in
`each'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_adapters/connection_specification.rb:160:in
`resolve_all'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/connection_handling.rb:70:in
`resolve'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/core.rb:46:in
`configurations='

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/core.rb:48:in
`block in <module:Core>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/concern.rb:120:in
`class_eval'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/concern.rb:120:in
`append_features'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/base.rb:291:in
`include'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/base.rb:291:in
`<class:Base>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/base.rb:275:in
`<module:ActiveRecord>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-5.1.6/lib/active_record/base.rb:25:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in
`load_dependency'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-session_store-1..1.1/lib/active_record/session_store/session.rb:7:in
`<module:SessionStore>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-session_store-1..1.1/lib/active_record/session_store/session.rb:5:in
`<module:ActiveRecord>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-session_store-1..1.1/lib/active_record/session_store/session.rb:4:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in
`load_dependency'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-session_store-1..1.1/lib/active_record/session_store.rb:111:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in
`load_dependency'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/activerecord-session_store-1..1.1/lib/activerecord/session_store.rb:1:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:96:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:96:in
`rescue in block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:73:in
`block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:66:in
`each'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:66:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler.rb:108:in
`require'

/opt/openproject/config/application.rb:70:in `<top (required)>'

/opt/openproject/Rakefile:33:in `require'

/opt/openproject/Rakefile:33:in `<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/rake-12.3.1/exe/rake:27:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in
`load'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in
`kernel_load'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:27:in
`run'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:360:in
`exec'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/command.rb:27:in
`run'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in
`invoke_command'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor.rb:369:in
`dispatch'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:20:in
`dispatch'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/base.rb:444:in
`start'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:10:in
`start'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/exe/bundle:30:in
`block in <top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/friendly_errors.rb:121:in
`with_friendly_errors'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/exe/bundle:22:in
`<top (required)>'

/opt/openproject/bin/bundle:3:in `load'

/opt/openproject/bin/bundle:3:in `<main>'

Caused by:

LoadError: cannot load such file -- activerecord-session_store

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:82:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:82:in
`block (2 levels) in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:77:in
`each'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:77:in
`block in require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:66:in
`each'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/runtime.rb:66:in
`require'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler.rb:108:in
`require'

/opt/openproject/config/application.rb:70:in `<top (required)>'

/opt/openproject/Rakefile:33:in `require'

/opt/openproject/Rakefile:33:in `<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/rake-12.3.1/exe/rake:27:in
`<top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in
`load'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:74:in
`kernel_load'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli/exec.rb:27:in
`run'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:360:in
`exec'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/command.rb:27:in
`run'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in
`invoke_command'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor.rb:369:in
`dispatch'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:20:in
`dispatch'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/vendor/thor/lib/thor/base.rb:444:in
`start'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/cli.rb:10:in
`start'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/exe/bundle:30:in
`block in <top (required)>'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/lib/bundler/friendly_errors.rb:121:in
`with_friendly_errors'

/opt/openproject/vendor/bundle/ruby/2.5.0/gems/bundler-1.15.2/exe/bundle:22:in
`<top (required)>'

/opt/openproject/bin/bundle:3:in `load'

/opt/openproject/bin/bundle:3:in `<main>'

(See full trace by running task with --trace)

root@Coordinacion:/home/coordinacion# openproject

Usage:

openproject run COMMAND [options]

openproject scale TYPE=NUM

openproject logs [--tail|-n NUMBER]

openproject config:get VAR

openproject config:set VAR=VALUE

openproject configure

openproject reconfigure

openproject restart

Details:

openproject configure [-f FILE|-]

* If using an installer:

This command will launch the installer wizard.

You can pass the installer seed file as argument or on STDIN.

* Without installer:

This will execute the configure script at
/opt/openproject/packaging/scripts/configure (if any).

A file containing environment variables can be given as argument or on
STDIN (-f -), and will be saved in the /etc/openproject/conf.d folder.

openproject reconfigure

This command allows to reconfigure the application. Only useful if using an
installer.

openproject restart [process]

This will restart the application (or the given process), in a
distribution-independent manner.

root@Coordinacion:/home/coordinacion#
Miguel Matos (06-11-2018, 15:50)
On Mon, Nov 5, 2018 at 7:56 PM quintocorreo <
quintocorreo> wrote:

[..]
> Module dav_svn already enabled
> [Mon Nov 05 13:14:18.661139 2018] [so:warn] [pid 3411] AH01574: module
> dav_module is already loaded, skipping


Pues no das muchas pistas sobre lo que sucede realmente, aparte de este
log, pero si lo indicas por este mensaje:

> AH00558: apache2: Could not reliably determine the server's fully
> qualified domain name, using 127.0.1.1. Set the 'ServerName' directive
> globally to suppress this message


Eso es porque el apache no reconoce un nombre de servidor establecido. Esto
se hace así: en el archivo apache.conf o httpd.conf (no recuerdo dónde es
que lo instala apache), busca una línea llamada ServerName. Si aparececon
'#', lo retiras, le escribes "localhost", y luego ejecutas [sudo
/etc/init.d/apache2 restart], y ya con eso dicho error se retira. Pero como
ahorita no tengo un debian disponible no puedo saber dónde están esos
archivos. Una segunda opción es buscar el directorio /etc/hosts y adicionar
esto:
[127.0.0.1 localhost
127.0.1.1 tunombredeservidor]
Y pasar la otra línea para reiniciar apache.

Your MPM seems to be threaded. Selecting cgid instead of cgi.
[..]
> "Cristo Viene pronto"
> «1 Tesalonicenses 4:17»
> Pues quizás echando un vistazo a la <a href="

https://www.openproject.org/download-and-installation/#configuration"
title="Install OpenProject - Free Download">Documentación de instalación de
OpenProject</a> pueda que te puedas cubrir algunas lagunas que tengas. Debo
decir que no lo conocía, así que tal vez cuando no tengas tantas presiones
en la oficina lo pueda probar.
Temas Similares